• 0
bels

Linux Wallet 2.0.2 stuck indexing

Question

I was able to get the linux wallet installed but it is stuck indexing.  I get "Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)" in the console that the wallet was started from.  Is there anything extra I need to do to run it on linux?  This is my first time, I have always ran it on windows before.  Thanks.

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Hello!

First make sure that WorldcoinDaemon process is running in the background when you execute the wallet, if it is not, make sure that the file has enough permissions and execution bit enabled (it is inside Daemons folder)

That message is unrelated to your problem

If solution above didn't work please send me WorldcoinBC.log file

Share this post


Link to post
Share on other sites
  • 0

hi, I wanted to test linux wallet but there was missing this:

libmng.so.1
libmysqlclient.so.18

I was only able to install the second package, when I wanted to install the first, there was this error:

Couldn't find any package by glob 'libmng.so.1'

what to do next?

Share this post


Link to post
Share on other sites
  • 0

The daemon is running but in the debug log in ~/.worldcoin i am getting this message: ThreadRPCServer incorrect password attempt from 127.0.0.1.  Could this message have anything to do with this?

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, marecek666 said:

hi, I wanted to test linux wallet but there was missing this:

libmng.so.1
libmysqlclient.so.18

I was only able to install the second package, when I wanted to install the first, there was this error:

Couldn't find any package by glob 'libmng.so.1'

what to do next?

For this you have to find the libmng1 package for your distribution.  I had this problem too but after tracking that down I was able to get the installer running.  What distro are you using?

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, marecek666 said:

hi, I wanted to test linux wallet but there was missing this:

libmng.so.1
libmysqlclient.so.18

I was only able to install the second package, when I wanted to install the first, there was this error:

Couldn't find any package by glob 'libmng.so.1'

what to do next?

That dependence is from one of the plugins of Qt  as we don't actually use this lib you can link libmng2 or whatever version  to libmng.so.1

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, bels said:

The daemon is running but in the debug log in ~/.worldcoin i am getting this message: ThreadRPCServer incorrect password attempt from 127.0.0.1.  Could this message have anything to do with this?

That's very odd,  did you install using the wizard? maybe you edited worldcoin.conf by hand?

Anyway make sure the varuable rpcpassword from worldcoin.conf (located in the block chain directory) matches matches the variable Password from Daemons.cfg

 

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, bels said:

For this you have to find the libmng1 package for your distribution.  I had this problem too but after tracking that down I was able to get the installer running.  What distro are you using?

Mint18

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Berzeck said:

That's very odd,  did you install using the wizard? maybe you edited worldcoin.conf by hand?

Anyway make sure the varuable rpcpassword from worldcoin.conf (located in the block chain directory) matches matches the variable Password from Daemons.cfg

 

That fixed it up.  But then it got stuck synchronizing at 0.0%.  The error in the .worldcoin/debug.log file is "trying connection 184.168.221.62:11081 lastseen=90.6hrs" over and over again.

Share this post


Link to post
Share on other sites
  • 0
21 minutes ago, marecek666 said:

this one does not work, there is nothing to install, system reported that it was not able to find package
https://postimg.org/image/v929b9zsh/

and "link over to libmng2" , it sounds well, but how to do it?

go to where your libmng2.so is and type "ln -s libmng2.so libmng1.so" and that should do it.

Share this post


Link to post
Share on other sites
  • 0

there is not any libmng2.so , via computer icon - search

I downloaded a file with name libmng-1.0.10.tar.gz and extracted all files, there are 2 readme files but nothing how to install it.

Share this post


Link to post
Share on other sites
  • 0

MAybe Qt 5.7.0 (which new wallet is using)  don't need those stupid dependencies (didn't test) when you do not use those plugins

If there is a chance I can test in your distro to tweak Linux version so it can directly support it without tweaking.

 

 

Share this post


Link to post
Share on other sites
  • 0

so I got this fixed.  I'm going to write up what I had to do when I get time today so others who have my problem can find help easily.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.